Porsche Macan Forum banner
61 - 78 of 78 Posts

·
Registered
Joined
·
405 Posts
Discussion Starter · #61 ·
Strictly CarPlay volume whether tethered via USB or bluetooth. If I go back to the radio as the source, the volume there works fine. The AUX volume has been maxed in the iSudar settings. Every other feature works as it should, I don't have any of the other quirky issues I see people having with back-up cameras, connectivity, etc....it just has low volume when using Carplay as the source.
Then check pcm settings, in the area were you can enable disable aux or aux BT you can also increase the max levels to make it louder and closer to your other volumes such as radio etc

Sent from my Pixel 6 using Tapatalk
 

·
Registered
Joined
·
2,044 Posts
Strictly CarPlay volume whether tethered via USB or bluetooth. If I go back to the radio as the source, the volume there works fine. The AUX volume has been maxed in the iSudar settings. Every other feature works as it should, I don't have any of the other quirky issues I see people having with back-up cameras, connectivity, etc....it just has low volume when using Carplay as the source.
The volume issue is fixed with the MCU firmware update.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
104 Posts
The volume issue is fixed with the MCU firmware update.


Sent from my iPhone using Tapatalk
If I try to DL either file, either from their google drive or their website, it's corrupted files and unable to unzip. Do you happen to have the files?
 

·
Registered
Joined
·
2,044 Posts
If I try to DL either file, either from their google drive or their website, it's corrupted files and unable to unzip. Do you happen to have the files?
PM’ing you….
 

·
Registered
Joined
·
104 Posts
Turns out, the iSudar unit does NOT like a SanDisk 1TB flash drive. Swapped to a 16gb one and everything went as planned. So for future reference, don’t use a big flash drive…

Thanks Santirx for getting me the files!!!
 

·
Registered
Macan S 2015
Joined
·
4 Posts
Updating the firmware fixed some of my issues. Volume control is fixed and the carplay can now recover from black screen freeze-out.

Problem with reverse camera that is connected to the carplay module:
When driving forward close to an obstacle, the car parking sensors activate in the backround. Now at this point when you switch to reverse, the reverse camera activation jams up the carplay and you cannot see the reverse camera picture. The screen goes black, Music stops, carplay turns off and PCM goes to oem park sensor image. The carplay unfreezes few seconds after you have already parked the car.

PRO TIP: If you have an aftermarket reverse camera, do not connect it to carplay module, as the carplay system does not work properly.
Find yourself another method by connecting the camera directly to your PCM.

Screen mirroring is a joke... I tested out the screen mirroring function with my iPhone Xs. To my surprise, the screen mirroring works only with wired connection, witch is a bummer. Other issue is that for example watching Youtube, the video and the sound is not in sync, witch makes the mirroring function completely useless to me. Additionally, the screen resolution is stretched to 4:3 distorting any other size of video aspect ratio. For comparison, I had a retrofit carplay in my previous old BMW e93, where the screen mirroring worked Wireless, properly synced and with perfectly fitted resolution... just saying.

In a nut shell, the "isudar" screen mirroring function is horrible and useless.

I wonder if they can fix these issues if this feedback would reach Isudar SW developers...
 

·
Registered
Joined
·
2 Posts
Hey everyone, I installed the Isudar CarPlay retrofit product in my PCM3.1. Everything went well but I have an audio issue:

the sound works only on the passenger side. I have the Bose Surround system installed. If I call someone via CarPlay, all speakers are working but if I stream Music or listen to a podcast, only the passenger side works. I tried to use the audio balance setting and it’s centered. I also just upgraded the firmware which solved the low volume issue for me but not the speaker issue.

Do you have any idea why the sound for audio streaming works only on the passenger side?

EDIT: for FM radio everything works fine, only audio in CarPlay mode works only on the passenger side.

Thank you!
Jo911
 

·
Premium Member
Joined
·
3,112 Posts
You have probably rechecked all cabling ……if that seems good you are down to a few things.

Bad board, or bad cables.

The ribbons, I would pull them and inspect the gold contact fingers….there has been some that were damaged ….causing no connection…..just an idea.


2016 MT
 

·
Registered
Joined
·
2,044 Posts
Hey everyone, I installed the Isudar CarPlay retrofit product in my PCM3.1. Everything went well but I have an audio issue:

the sound works only on the passenger side. I have the Bose Surround system installed. If I call someone via CarPlay, all speakers are working but if I stream Music or listen to a podcast, only the passenger side works. I tried to use the audio balance setting and it’s centered. I also just upgraded the firmware which solved the low volume issue for me but not the speaker issue.

Do you have any idea why the sound for audio streaming works only on the passenger side?

EDIT: for FM radio everything works fine, only audio in CarPlay mode works only on the passenger side.

Thank you!
Jo911
If FM works well, your MOST bus wire is OK and it is connected. It may be a wire that is not seated well in its connector in the Isudar board. The reason you can hear calls, is because if your phone is still paired to PCM, the call is actually made through the PCM even though you are seeing it in the CP screen.

I would start by inspecting and re-seating all wires/connectors in the Isudar Board. Also, the quad lock.

Good luck.
 

·
Registered
Joined
·
2 Posts
If FM works well, your MOST bus wire is OK and it is connected. It may be a wire that is not seated well in its connector in the Isudar board. The reason you can hear calls, is because if your phone is still paired to PCM, the call is actually made through the PCM even though you are seeing it in the CP screen.

I would start by inspecting and re-seating all wires/connectors in the Isudar Board. Also, the quad lock.

Good luck.
Thank you. I removed the entire unit and re-seated all wires and connectors. Sound is still only on the passenger side. Any other ideas?

Thanks a lot!!
 

·
Premium Member
Joined
·
3,112 Posts
Anyone not able to change SOURCE after installing the Isudar (or others)? I am stuck on FM radio, but can't hear anything anyway. SOURCE button just takes me to a System Info screen that tells me System version: v4.75, PCM3.1, Serial Number XXxxx, and has buttons for "Current system" and "History". Otherwise I'm able to connect to CarPlay without issue. Unfortunately with the current situation I've also lost the ability to listen to music via radio, bluetooth, etc. as well as making calls.
I would upgrade to PCM 4.76 first....... then re check
 

·
Premium Member
Joined
·
3,112 Posts
@Santirx , @notmac1 just successfully completed the iSudar install , VER 1.2
He is on 0927 now. Would you suggest he does MCU upgrade, than 1124 ? ? or is MCU now bundled into 1124 ? thanks !
 

·
Premium Member
Joined
·
1,381 Posts
@Santirx , @notmac1 just successfully completed the iSudar install , VER 1.2
He is on 0927 now. Would you suggest he does MCU upgrade, than 1124 ? ? or is MCU now bundled into 1124 ? thanks !
@Teddis @Santirx A big shout out to both. I installed the SSD drive per Santrix instructions everything went perfect. Then went after the Isudar install after the hard drive checked out perfect. Terry owe you big for all the help and face time you made the final check out seamless. Saved big time no don't need a new car to get Car Play. Looking forward to the info and location to get the update to finalize the volume control issue with the update. Couldn't have done it or tried it without you guys.
 
  • Like
Reactions: Santirx

·
Registered
Joined
·
2,044 Posts
Good to hear @notmac1

Since the FW updates are independent, one for MCU (i.e. volume) and the other is for SOC, the order really doesn’t matter.

But… do MCU first, then SOC. I copied the files in following link:

Isudar Firmware Update - Google Drive

The volume issue is fixed by upgrading MCU (see MCU folder). To check if you have the volume issue, when in CarPlay, if you see a volume bar in the CarPlay screen when you turn PCM volume (in the actual PCM, not the steering wheel), then you need to update the MCU Firmware. What happens is that the volume in PCM is maximized by the volume in steering wheel (PCM is slave to steering).

The 1124 firmware you find in the Board v1.2/2.0 folder.

To update, you need to use the USB port that is directly attached to the Isudar module.

Wait until the update is complete. You’ll see a thin white bar, and that bar will be progressing until completely gray. Do not interrupt the process or you will brick the module. Is really not complex…

Good luck!
 

·
Premium Member
Joined
·
3,112 Posts
he has the volume issue for sure......so just like @santrix says @notmac1 , mcu, then soc. Do them independently with a newly loaded usb each time.
 

·
Registered
Joined
·
1 Posts
Good to hear @notmac1

Since the FW updates are independent, one for MCU (i.e. volume) and the other is for SOC, the order really doesn’t matter.

But… do MCU first, then SOC. I copied the files in following link:

Isudar Firmware Update - Google Drive

The volume issue is fixed by upgrading MCU (see MCU folder). To check if you have the volume issue, when in CarPlay, if you see a volume bar in the CarPlay screen when you turn PCM volume (in the actual PCM, not the steering wheel), then you need to update the MCU Firmware. What happens is that the volume in PCM is maximized by the volume in steering wheel (PCM is slave to steering).

The 1124 firmware you find in the Board v1.2/2.0 folder.

To update, you need to use the USB port that is directly attached to the Isudar module.

Wait until the update is complete. You’ll see a thin white bar, and that bar will be progressing until completely gray. Do not interrupt the process or you will brick the module. Is really not complex…

Good luck!

This update works with EBILAEN module?
 

·
Registered
Joined
·
2,044 Posts
This update works with EBILAEN module?
Yes! They are the same thing… Isudar / Ebilaen…

At least for board version 1.2.

I’m not sure if Ebilaen is offering v2.0 of the board, like Isudar is.
 
61 - 78 of 78 Posts
Top