Porsche Macan Forum banner
21 - 40 of 67 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #21 ·
So Waze works flawlessly on Android Auto, but when I try to use Waze from the OS interface, I getting nothing. It renders where I am, but when I start moving it does nothing. I connected the dongle via my phone hotspot and can get YouTube, Spotify, Google Maps, etc. but not Waze. Any ideas?
Does Waze indicate any issues (No Network or GPS signal)? First thing to try is make sure Waze is updated to the latest version (just go to google play, search for waze and see if an update is available).

Next make sure you have a GPS signal. There is an app that was installed on mine called GPS Test: GPS Test - Apps on Google Play
Run that or install if its not on your box and make sure you get a good signal. If poor then may need to move the box or not keep it in the armrest.

If no GPS signal then you may have OEM GPS selected. On mine this is under CUSP settings but yours may say ApplePie or something else:

Computer Personal computer Font Communication Device Gadget


The system can't use OEM GPS data on my 2018.

Also, enable High GPS Location accuracy in settings --> Location --> Google Location Accuracy
Computer Personal computer Font Gadget Output device


Final thing is make sure Waze has location services enabled: settings --> apps --> waze --> app permissions

Computer Personal computer Output device Gadget Font


If none of that works then I'd also try uninstalling Waze and re-install from the play store.
 

·
Registered
Joined
·
322 Posts
I am sooooooo all over this. I have a 2018 optioned with CarPlay (but I have a Samsung S21 Ultra). You're telling me that I can get plug and play Android Auto just by connecting this unit through the factory USB in the center console similar to how my wife does with her iPhone to get CarPlay? This must be too good to be true, but call me a skeptic.

On Amazon do I order the $209.49 version or the $199.99 version? This looks AWESOME!!!! Can't wait.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #23 · (Edited)
Hey @jmoney:
Thank you for your explanation so far. I'm just trying to understand what this box does - before taking the plunge. Plese tell me if my understanding is correct:

When I connect the box via USB to the Macan (I have a 2021) it takes over the infotainment screen, replacing the Porsche native functionality. then, when I pair the phone to the box (using a Samsung in this case), I can use Android Auto to do all the things it can do (Waze, etc.) - but not any of the native Porsche functions (music, GPS, etc.)

Do I have a correct understanding - or am I missing something? TIA for your assistance here.
You can still use all of the Porsche native functions too. I still use my Jukebox sometimes to play music while using the AI Box's GPS apps / Carplay. You can also use Porsche navigation while using the box -- on mine I can use the cluster display to also show the built-in NAV and have android apps / carplay running on the main screen. I think Carplay only takes up part of the screen on the 2021? So that is what will be used with this box. The right hand side would still show Porsche apps etc.

I did run into one issue when using both Porsche NAV and built-in Waze at the same time. Waze speaking directions seemed to cancel out Porsche NAV directions and Porsche NAV stopped providing directions. But I don’t usually run two GPS at the same time.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #24 ·
I am sooooooo all over this. I have a 2018 optioned with CarPlay (but I have a Samsung S21 Ultra). You're telling me that I can get plug and play Android Auto just by connecting this unit through the factory USB in the center console similar to how my wife does with her iPhone to get CarPlay? This must be too good to be true, but call me a skeptic.

On Amazon do I order the $209.49 version or the $199.99 version? This looks AWESOME!!!! Can't wait.
Hmm on my Amazon it shows $188.49 when signed in (if not signed in it shows a higher price -- weird). I have a 2018 Macan S and use the 2016-2021 version but there is also a 2016-2022 version . Either should work the same -- I'd just get which ever one is showing up cheaper if you have the 2018.
 

·
Registered
Joined
·
322 Posts
Hmm on my Amazon it shows $188.49 when signed in (if not signed in it shows a higher price -- weird). I have a 2018 Macan S and use the 2016-2021 version but there is also a 2016-2022 version . Either should work the same -- I'd just get which ever one is showing up cheaper if you have the 2018.
Strange that the pricing would show up different for me, and I even used my VPN to try a few different locations in the US, all with the same pricing...no big deal. Oddly enough, the 2016-2022 version is the less expensive item.

The 2016-2022 model indicates "For Original Touchscreen" $199.99
The 2016-2021 model indicates "For Factory Wired CarPlay (Touch)" $209.49
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #26 ·
Strange that the pricing would show up different for me, and I even used my VPN to try a few different locations in the US, all with the same pricing...no big deal. Oddly enough, the 2016-2022 version is the less expensive item.

The 2016-2022 model indicates "For Original Touchscreen" $199.99
The 2016-2021 model indicates "For Factory Wired CarPlay (Touch)" $209.49
Shows a higher price for me if I’m not signed in to Amazon. I also have prime. Not sure if that matters. But yeah I’d get the cheaper 2022 one.
 

·
Registered
Joined
·
322 Posts
Shows a higher price for me if I’m not signed in to Amazon. I also have prime. Not sure if that matters. But yeah I’d get the cheaper 2022 one.
Ordered the 2016-2022 one. Thanks Jmoney, can't wait to try it out!!
 

·
Registered
Joined
·
13 Posts
Does Waze indicate any issues (No Network or GPS signal)? First thing to try is make sure Waze is updated to the latest version (just go to google play, search for waze and see if an update is available).

Next make sure you have a GPS signal. There is an app that was installed on mine called GPS Test: GPS Test - Apps on Google Play
Run that or install if its not on your box and make sure you get a good signal. If poor then may need to move the box or not keep it in the armrest.

If no GPS signal then you may have OEM GPS selected. On mine this is under CUSP settings but yours may say ApplePie or something else:

View attachment 250090

The system can't use OEM GPS data on my 2018.

Also, enable High GPS Location accuracy in settings --> Location --> Google Location Accuracy
View attachment 250091

Final thing is make sure Waze has location services enabled: settings --> apps --> waze --> app permissions

View attachment 250092

If none of that works then I'd also try uninstalling Waze and re-install from the play store.
Hey @jmoney, Thanks for all the great suggestions. Now that I think of it, its probably is a GPS issue. And you are right about the OEM GPS. The one time I unchecked it was the one time it worked for about 10 minutes -- and then it crapped out, probably because the Mini is tucked in the center console arm rest. Will also look for the GPS accuracy setting. Not sure I have it, but will look. You rock. (y)(y)(y)
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #29 ·
Hey @jmoney, Thanks for all the great suggestions. Now that I think of it, its probably is a GPS issue. And you are right about the OEM GPS. The one time I unchecked it was the one time it worked for about 10 minutes -- and then it crapped out, probably because the Mini is tucked in the center console arm rest. Will also look for the GPS accuracy setting. Not sure I have it, but will look. You rock. (y)(y)(y)
Yeah you have the 2022 which may have more shielding in the armrest. GPS usually works better if it’s uncovered / has line of sight through the windshield.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #30 · (Edited)
Ordered the 2016-2022 one. Thanks Jmoney, can't wait to try it out!!
Just a heads up with Android Auto. Many people are complaining about the Samsung phones not being able to get it to work right away with cars that have it installed by default. So you may have to play around with it a bit. Here's a thread on the issues they are seeing (not related to this AI Box), but I think this was related to a cable issue: Cannot use Android Auto with new S21 Ultra
 

·
Registered
Joined
·
322 Posts
Just a heads up with Android Auto. Many people are complaining about the Samsung phones not being able to get it to work right away with cars that have it installed by default. So you may have to play around with it a bit. Here's a thread on the issues they are seeing (not related to this AI Box), but I think this was related to a cable issue: Cannot use Android Auto with new S21 Ultra
Thanks for the heads up! I have a variety of cables and adapters that I've accumulated from various products, so it sounds like I'll have some experimenting to do.
 

·
Registered
Joined
·
13 Posts
Hey @jmoney. Just wanted to thank you for the advice and guidance. Yes, it was the GPS signal. I took the dongle out of the armrest and Waze worked perfectly. I guess what I could not understand is why Waze worked on AA and not the Mini OS. Then figured out that the AA Waze worked off my phone GPS and the Mini OS needed the GPS in the dongle. Now I gotta figure out when to "hide" the dongle in plain sight. :) An interesting side note is that I was getting some apps that worked on the Mini OS and not others. For example, Google Maps worked, YouTube worked, but doing a Google search did not. Some other apps I downloaded said "no internet connection". When I connected AA through wifi, I got internet connection. Why would Google Maps and YouTube work without wifi connection (internet) and others not? I thought the dongle provided an internet connection since it was using my phone as a hotspot. Thanks again!
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #33 · (Edited)
Hey @jmoney. Just wanted to thank you for the advice and guidance. Yes, it was the GPS signal. I took the dongle out of the armrest and Waze worked perfectly. I guess what I could not understand is why Waze worked on AA and not the Mini OS. Then figured out that the AA Waze worked off my phone GPS and the Mini OS needed the GPS in the dongle. Now I gotta figure out when to "hide" the dongle in plain sight. :) An interesting side note is that I was getting some apps that worked on the Mini OS and not others. For example, Google Maps worked, YouTube worked, but doing a Google search did not. Some other apps I downloaded said "no internet connection". When I connected AA through wifi, I got internet connection. Why would Google Maps and YouTube work without wifi connection (internet) and others not? I thought the dongle provided an internet connection since it was using my phone as a hotspot. Thanks again!
If you're using Carplay then it disables the wifi connection and the mini-os apps (Android OS) shouldn't have connectivity. I'm not sure if Android Auto does the same but I think they work similar. If you want to use the mini-OS apps then you need to make sure the connection to Carplay / Android auto is completely disabled -- for instance, I need to enable the wifi on my Iphone and it will ask me if I want to disconnect carplay. I would then be able to use my hotspot to connect the AI Box. If you go into the WIFI settings for the applepie then it should show you which SSID you're connected to. When connected to Carplay it shows WiFI as 'Off' for me.

Google Maps does cache map data so it can be used offline (with limited range) when you don't have a network connection. Not sure about youtube though but you shouldn't be able to view videos while connected to Android Auto / Carplay.

If you wanted to use both at the same time then you could get a SIM card to put into the AI Box. That would give the unit a dedicated network connection but is an added monthly cost for most phone carriers.
 

·
Registered
Joined
·
13 Posts
If you're using Carplay then it disables the wifi connection and the mini-os apps (Android OS) shouldn't have connectivity. I'm not sure if Android Auto does the same but I think they work similar. If you want to use the mini-OS apps then you need to make sure the connection to Carplay / Android auto is completely disabled -- for instance, I need to enable the wifi on my Iphone and it will ask me if I want to disconnect carplay. I would then be able to use my hotspot to connect the AI Box. If you go into the WIFI settings for the applepie then it should show you which SSID you're connected to. When connected to Carplay it shows WiFI as 'Off' for me.

Google Maps does cache map data so it can be used offline (with limited range) when you don't have a network connection. Not sure about youtube though but you shouldn't be able to view videos while connected to Android Auto / Carplay.

If you wanted to use both at the same time then you could get a SIM card to put into the AI Box. That would give the unit a dedicated network connection but is an added monthly cost for most phone carriers.
Well, when I went on my hotspot, I think that AI Box did turn Wifi off, but I did turn it on manually. After I did that, internet connectivity worked. I was not watching Youtube on AA, it was on the Mini's OS. So the question is, why there was not internet connectivity through the hotspot and only when I turned wifi on. I can understand intuitively that there might be conflicts having a hotspot and wifi on at the same time, but this scenario seemed to work for me.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #35 ·
Well, when I went on my hotspot, I think that AI Box did turn Wifi off, but I did turn it on manually. After I did that, internet connectivity worked. I was not watching Youtube on AA, it was on the Mini's OS. So the question is, why there was not internet connectivity through the hotspot and only when I turned wifi on. I can understand intuitively that there might be conflicts having a hotspot and wifi on at the same time, but this scenario seemed to work for me.
Ahh I think I see what you did. If you turn on the AI Box's wifi then it will disconnect Android Auto but then you can watch youtube videos etc. I just tested on my system and when I turned on Wifi it disconnected Carplay in the Speedplay app. To start using Carplay again I would need to connect my Iphone to bluetooth and then it would disconnect the Wifi connection to my phone's hotspot.

There is also an Android app called Carstream / Youtubeauto that will let you watch youtube videos while in Android Auto but you need to be rooted. Obviously not on the play store.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #38 ·
Anyone know where I can get the latest firmware CUSP AI Box?
Their support just got back to me today with a link to the latest firmware (I haven't updated mine yet). Looks like it expires in 24 hours so you'll have to contact support for a new link if you don't download it soon enough:

 

·
Registered
Joined
·
2 Posts

·
Registered
Joined
·
13 Posts
Ahh I think I see what you did. If you turn on the AI Box's wifi then it will disconnect Android Auto but then you can watch youtube videos etc. I just tested on my system and when I turned on Wifi it disconnected Carplay in the Speedplay app. To start using Carplay again I would need to connect my Iphone to bluetooth and then it would disconnect the Wifi connection to my phone's hotspot.

There is also an Android app called Carstream / Youtubeauto that will let you watch youtube videos while in Android Auto but you need to be rooted. Obviously not on the play store.
Hey @jmoney. After playing with the Mini for a few days now, think I have the hang of it. I do find that the Mini OS is much more robust and has more deliverables than AA. The way it is now, AA boots up automatically after the Mini OS starts, connects with my phone, and opens up to the last application it was on. Not sure I know what I did to have it auto start, but I'd rather have Apple Pie auto start in the Mini OS and not start AA. Have any idea how to do that? Did not see anything in AA settings. As always, thanks. .
 
21 - 40 of 67 Posts
Top